[UFO Chicago] the story thus far -- the end?

Peter A. Peterson II pedro@tastytronic.net
Thu, 19 Jul 2001 01:49:03 -0500

Well, here's the story thus far.

Ok, well, you know a lot of the story thus far; here are the new parts.

Tonight and last night, Jack Edwards and I debugged flynn's problems. 

I wondered (thanks to Jack) if the problems booting on the uniprocessor
board were because the board could not support an SMP kernel -- some
(many?) boards can, but some can't. I would also assume that newer
boards are more apt to be able to handle it -- and Pentium Pro boards
aren't exactly "modern". SO, I tried to boot off of an old HD that had
"That Other Operating System"  on it. No dice. In fact, it seemed like
the hard drives were not being detected at all. Now, I thought these
were good drives, but... who knows. SO I knew that this wasn't a
conclusive test, and built a Pentium-class uniprocessor Linux kernel,
with the intention of trying to boot this board with it.

Tonight, we did just that. At first we ran into some weird problems --
namely, the machine would not boot with the PCI cards in a particular
order, so I had to shuffle them around in order to make the machine
work. Do you know why this might be? It was my understanding that
certain boards would only allow the video card to be in a particular
slot. But I don't know. Once we hammered that out, we used Jack Edwards'
ide hard drive and cable from his box "thedude" to test things out. It
worked great. So we tried the same set up with the other Pro processor.
Again, not a hitch. 

"Hum," we thought, "this is most interesting."

So, with SCSI card, NIC, NIC (flynn has two nics), Video, RAM, and disk
array all functional, we turned our eyes back to the one-of-a-kind,
no-longer-available motherboard. We hooked everything back up in its
usual configuration and booted. Same crappy problem.

Then we decided to try turning things off in the BIOS (particularly
because flynn was complaining about the floppy drive not being connected
(which it wasn't)). We turned of every device that wasn't necessary
(within reason). This meant that we left the L2 cache on (since the
processors seemed to be ok), but turned off all COM ports, onboard IDE,
etc., etc., and rebooted. It came up like a charm. So then we rebooted,
several times, reenabling one device at a time. Finally, we ended up
right back where we started, with flynn working just like it used to.

So I have no idea what happened. Was it heat? Was it humidity? Was it a
confused BIOS? Was it solar flares? No clue.

What a long strange trip it's been.


PS: Does anyone else think it's an odd coincidence that both my and
Jack's computer are named after movie characters played by Jeff Bridges?

Peter A. Peterson II, CEO Users of Free Operating Systems, Chicago USA
http://ufo.chicago.il.us -- Free Software Rules -- Proprietary Drools!